Intermittent issues with some document setup functionality
Incident Report for SignWell
Postmortem

This issue was resolved in about 30 mins from when first reported. A system side configuration issue was the cause and we’ve enhanced our standard release process to ensure this type of issue doesn’t happen in the future.

Posted Mar 12, 2021 - 15:16 PST

Resolved
Some customers may see issues setting up or uploading documents.
Posted Mar 02, 2021 - 15:10 PST