Infrastructure issues
Incident Report for SignWell
Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 15:52 PDT
Update
Everything is operational again. Thank you for your patience!
Posted Aug 31, 2021 - 15:51 PDT
Update
We are continuing to investigate this issue.
Posted Aug 31, 2021 - 12:48 PDT
Investigating
We're currently experiencing infrastructure issues with our host (Amazon AWS). They're aware of the problems and are working to get everything back. We'll update once everything is back up. We're sorry about the trouble and any inconvenience this has caused.
Posted Aug 31, 2021 - 12:20 PDT
This incident affected: Docsketch Service.