Document sending encountering temporary deliverability issues

Incident Report for SignWell

Resolved

Our email service provider has resolved the issue, and all queued-up emails have been delivered.
Posted Sep 16, 2025 - 14:00 PDT

Monitoring

We monitoring email deliverability.
Posted Sep 16, 2025 - 13:45 PDT

Investigating

We are working on a way to resume deliverability.
Posted Sep 16, 2025 - 09:42 PDT
This incident affected: Docsketch Service.